Lilt website 'https://lilt.com/' is down.
Incident Report for Lilt
Resolved
This incident has been resolved. Lilt website is now up and running.
Posted Apr 26, 2024 - 11:34 CEST
Investigating
We are currently investigating this issue.
Posted Apr 26, 2024 - 11:30 CEST
This incident affected: Static Content (Homepage).