Degraded app performance
Incident Report for Lilt
Resolved
The problem was resolved. All systems are back to normal.
Posted over 1 year ago. Apr 18, 2018 - 13:25 UTC
Investigating
Users might be experiencing degraded app performance at the moment. We're looking into it!
Posted over 1 year ago. Apr 18, 2018 - 12:29 UTC