Services interruption
Incident Report for Lilt
Resolved
All services have been restored.
Posted over 1 year ago. Feb 19, 2018 - 16:39 UTC
Investigating
Some regions are reporting extensive lag. We're working on it. We're very sorry for the inconvenience!
Posted over 1 year ago. Feb 19, 2018 - 15:59 UTC