Sign in page unavailability
Incident Report for Lilt
Postmortem

Resolved

On Wednesday, 10 April 2019, Lilt's sign in page was unavailable from 12:45 a.m. to 2:06 am Pacific Time.

The sign in page became unavailable due to an incompatibility introduced when updating a library to support internationalized content in the application. All parts of the application where the internationalization library was updated were tested thoroughly. The failure was located in a part of the application that is temporarily being maintained separately from the rest of the application while we're adding support for full internationalization. In this case, we overlooked this part of the codebase when updating support for internationalization.

The earliest report was at 1:08 am PT. Fortunately, in this situation, we were able to respond immediately upon becoming aware of the failure to resolve it. We informed the four known users about the nature of the failure along with the time when they could again expect to sign into the application. Additionally, these users were notified upon verifying sign in functionality had been restored.

We apologize for this oversight and the inconvenience it caused and have started taking steps to mitigate this particular type of failure in the future, including automated application testing to help ensure the application cannot be released into production when such a failure is present.

Posted Apr 11, 2019 - 07:50 CEST

Resolved
The sign in page became is unavailable due to an incompatibility introduced when updating a library to support internationalized content in the application.

The earliest report was at 1:08 am PT. We've identified a solution and will work to restore the ability to sign immediately.
Posted Apr 10, 2019 - 11:06 CEST
This incident affected: Translate (Translate).