Slow page loading
Incident Report for Lilt
Resolved
This incident has been resolved.
Posted Sep 06, 2021 - 20:54 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 06, 2021 - 18:26 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 06, 2021 - 18:14 CEST
Investigating
Some users might experience slow page loading time. We are currently investigating this issue.
Posted Sep 06, 2021 - 14:37 CEST
This incident affected: Manage and Translate (Translate).