Can't assign Linguists

Incident Report for Lilt

Resolved

This incident has been resolved.
Posted Jan 31, 2023 - 13:15 CET

Investigating

Our team is currently investigating an issue where users are unable to assign Linguists within the platform.
Posted Jan 31, 2023 - 10:58 CET
This incident affected: Manage.