LILT App pages loading slowly

Incident Report for Lilt

Resolved

The latency issue has been resolved and all platform tasks are on schedule. We appreciate your patience
Posted Dec 18, 2024 - 04:04 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 17, 2024 - 21:27 CET

Update

We are committed to resolving this issue promptly and will keep you updated on our progress.
Posted Dec 17, 2024 - 16:13 CET

Investigating

We are currently investigating this issue.
Posted Dec 17, 2024 - 10:00 CET
This incident affected: Linguist Experience (CAT Editor) and Manage.