Batch translation requests failing or delayed

Incident Report for Lilt

Resolved

The issue with batch translation has been resolved.
Posted Apr 14, 2026 - 03:47 CEST

Monitoring

The issue has been identified and we've pushed a fix; we're monitoring to ensure its efficacy.
Posted Apr 14, 2026 - 03:11 CEST

Investigating

We are actively investigating this issue. This impacts both Instant Translate and pre-translation.
Posted Apr 14, 2026 - 00:44 CEST
This incident affected: Translate (Instant > AI Review).