GCP Service Degradation

Incident Report for Lilt

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 19:17 CEST

Monitoring

Google Cloud Provider (GCP) is experiencing a degradation in performance. You may notice application slowness while using LILT while this degradation of service continues.
Posted Sep 01, 2026 - 18:06 CEST