Website outage
Incident Report for Lilt
Resolved
This incident has been resolved.
Posted Nov 04, 2020 - 20:37 CET
Investigating
We are investigating an issue with the lilt.com website. The application can still be accessed via direct URLs such as https://lilt.com/signin.
Posted Nov 04, 2020 - 20:29 CET
This incident affected: Translate (Translate).