Platform Degraded Performance
Incident Report for Lilt
Resolved
This incident has been resolved.
Posted Jan 20, 2025 - 19:55 CET
Investigating
We are currently investigating this issue.
Posted Jan 20, 2025 - 18:26 CET
This incident affected: Connect (API) and Translate, Linguist Experience.