lilt.com Homepage Not Loading

Incident Report for Lilt

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 11:20 CEST

Identified

We’ve identified this as a regional and browser-specific issue. We are reviewing the impact.
Posted Apr 27, 2026 - 10:43 CEST

Investigating

We are currently investigating this issue.
Posted Apr 27, 2026 - 08:59 CEST
This incident affected: Static Content (Homepage).