App Performance issue
Incident Report for Lilt
Resolved
This incident has been resolved.
Posted Sep 24, 2019 - 22:32 CEST
Monitoring
Issue has been identified and resolved. Monitoring for any other anomalies.
Posted Sep 24, 2019 - 22:30 CEST
Investigating
We are currently investigating this issue.
Posted Sep 24, 2019 - 21:56 CEST
This incident affected: Translate (Translate) and Manage.