Lilt is down

Incident Report for Lilt

Resolved

This incident has been resolved, things are operational and are actively being monitored.
Posted Sep 16, 2026 - 04:04 CEST

Monitoring

We are monitoring for more issues, things are stable and working now.
Posted Sep 16, 2026 - 04:01 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 16, 2026 - 03:26 CEST
This incident affected: Lilt Website (lilt.com) (Homepage) and Sign-in & Account Access.