App unavailable

Incident Report for Lilt

Resolved

The cause of the outage has been identified and service has been restored.
Posted Oct 30, 2025 - 19:04 CET

Investigating

We are currently investigating this issue.
Posted Oct 30, 2025 - 18:43 CET
This incident affected: Connect (API), Translate (Translate), and Manage.