LILT Performance Degradation

Incident Report for Lilt

Resolved

This incident has been resolved.
Posted Dec 20, 2024 - 13:50 CET

Identified

The issue has been identified.

Please use https://europe.lilt.com/app/home for fast platform usage.
Posted Dec 20, 2024 - 13:03 CET

Update

The problem has been localized to users in Europe. LILT in American and Asia-Pacific is operating normally.
Posted Dec 20, 2024 - 12:05 CET

Investigating

The LILT platform's performance has degraded with users seeing blank pages and long loading times.
Posted Dec 20, 2024 - 10:51 CET
This incident affected: Translate and Manage.