Degraded Editor Performance

Incident Report for Lilt

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 16:45 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 08, 2025 - 16:28 CEST

Update

We are continuing to investigate this issue.
Posted Oct 08, 2025 - 16:05 CEST

Investigating

Some LILT users are experiencing degraded performance broadly on LILT.com. We are investigating the root cause.
Posted Oct 08, 2025 - 14:22 CEST
This incident affected: Connectors & Integrations (API, Connectors & Integrations), Editor & Workspace (CAT) (CAT Editor), Translation API & Machine Translation (Translate), and Jobs, Projects & Workflows.