Platform Performance Issues
Incident Report for Lilt
Resolved
This incident has been resolved.
Posted Apr 13, 2022 - 22:07 CEST
Update
We are continuing to work on a fix for this issue.
Posted Apr 13, 2022 - 18:27 CEST
Identified
Lilt editor is slow and users have reported issues confirming segments. The engineer team is aware and working on a resolution.
API Requests and Sign-In are also experiencing degraded performance at this time.
Posted Apr 13, 2022 - 17:53 CEST
This incident affected: Connect (API), Translate (Translate), and Manage.